Page 5 of 5 FirstFirst 12345
Results 41 to 45 of 45

Thread: 1.3w 650nm cni maybe rubbish?

  1. #41
    Join Date
    Jul 2007
    Location
    west sussex uk
    Posts
    2,279

    Default

    Hey adam
    Yes they are p73's and yes they are well cooled to around 5 deg in a sealed case and some silica packs
    Running at around 1200ma
    There will be a 10-12w rgb build thread coming with lots pics


    Quote Originally Posted by norty303 View Post
    Badger, you say thats a quad 4W module, I take it the whole thing is quite heavily TECed and they are the 73 mitsus?
    What current are you driving them at?
    When God said “Let there be light” he surely must have meant perfectly coherent light.

  2. #42
    Join Date
    Jan 2013
    Location
    Gisborne NZ
    Posts
    79

    Default

    so heres a few pics
    I still have to finish the case and I think I will re do all my dichro mounts for something more solid but Im pretty happy for a first attempt
    I got into an indoor hall/bball court for some trials
    Im pretty happy with it but now I have an overwhelming urge to build a bigger better one

    I THINK ITS AN ADDICTION

    Click image for larger version. 

Name:	IMG_0836.JPG 
Views:	31 
Size:	227.2 KB 
ID:	36874Click image for larger version. 

Name:	IMG_0835.JPG 
Views:	30 
Size:	228.6 KB 
ID:	36875Click image for larger version. 

Name:	DSC05192.jpg 
Views:	24 
Size:	138.0 KB 
ID:	36876Click image for larger version. 

Name:	DSC05191.JPG 
Views:	14 
Size:	112.6 KB 
ID:	36877Click image for larger version. 

Name:	DSC05205.JPG 
Views:	16 
Size:	135.5 KB 
ID:	36878Click image for larger version. 

Name:	DSC05209.JPG 
Views:	17 
Size:	109.5 KB 
ID:	36879

  3. #43
    Join Date
    Oct 2010
    Location
    Athens, Greece
    Posts
    1,931

    Default

    So glad you stirred clear of that 650nm and managed to finish succesfully the 638nm 1watter in no time.
    make sure you monitor the working temp, you may have to add additional heatsinking (for example ram or vga chip heatsinks on top of the diode mounts)

    I will pretend I didn't see that iTrust board in there for now (as i pretend not to see such a board in one of my boxes, too )
    Just be carefull as it tends to shoot out a full power static beam when changing from dmx to ilda (i.e. when un/plugging an ilda cable)

    An excellent replacement dichro mount can be newport MM1 mounts (or equivalent from thor labs or clones).
    They tend to go around ebay for 40usd each, maybe less if you are lucky


    Thanks for the pics, it looks very nice!
    "its called character briggs..."

  4. #44
    Join Date
    Jul 2007
    Location
    west sussex uk
    Posts
    2,279

    Default

    a word of warning , you might want to get the red sealed up in a box.
    as i found out at the last uklem for some reason fog juice loves red lasers more , and it shitted up my optics so bad the red was down to a mere glow in a matter of hours
    i have no idea why but it did , the blue and green where fine, after a quick clean power was back, but two hours later shitted up again.
    anyone else get this problem ?
    When God said “Let there be light” he surely must have meant perfectly coherent light.

  5. #45
    Join Date
    Jan 2013
    Location
    Gisborne NZ
    Posts
    79

    Default

    Haha yep the board came with the scanners It is a tempory thing theres two TEC pads under the red and one under the blue they get the plate pretty cold they are run in series off the 1.5a 12v psu just on all the time.
    Im going to have one more crack at building my mirror mounts SLOWLY I tend to get excited and want to throw something together to see some BEAMS

    Cheers badger I will also put the red in a case infact I will probably put both the red and blue in cases

    Thanks again for all your help guys much appreciated!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •