Page 4 of 5 FirstFirst 12345 LastLast
Results 31 to 40 of 44

Thread: Ether Dream 2

  1. #31
    Join Date
    Feb 2018
    VA <-> NYC


    @j4cbo - Another quick question in addition to the static IP question. Is there comprehensive documentation that replaces the etherdream 1 online docs? I'm interested in knowing what the status codes are that the etherdream is returning - Specifically response codes 73 & 97 during some glitches, I'm assuming I'm not filling the buffer enough at times. Thanks! So far running smoothly with 4x Etherdreams on a gigabit switch!

  2. #32
    Join Date
    Oct 2016
    Eugene, OR


    Is there comprehensive documentation that replaces the etherdream 1 online docs? I'm interested in knowing what the status codes are that the etherdream is returning - Specifically response codes 73 & 97 during some glitches
    The protocol has not changed. The page is kind of buried, but the response codes are here. Note, they are all given in hex values and your values above appear to be decimal.

  3. #33
    Join Date
    May 2018


    Where's the source code for the ED2 firmware? There's a download page that links to the source, but that has a big notice saying it only applies to EtherDream 1 and links to the new site. But on the new site I only see a binary download. And the latest ED2 firmware is dated March 10, 2018, but the Github repo hasn't been updated nearly that recently.

  4. #34
    Join Date
    Dec 2017


    Hello. A week ago I bought an EtherDream 2 controller in Innolasers. I synchronized DAC with LSX Basic, it works well. Then he put Etherdream-tools, it works well too. UDP port 7654 is opened.

    The question is: my projector should work on the street, on the electric lighting support, so I have to run ild files automatically, from the memory card.

    What I did: prepared a memory card 8g., Class 10, fat32. We downloaded ild files onto this card (I tried the format 0 1 and 4 5). Created autoplay.txt :
    / ilda / pps 30000
    / ilda / fps 30
    / geom / size 0.3
    / geom / offset 0.4 -0.2
    / ilda / play file.ild

    Unfortunately, automatic playback does not start. I also tried to send OSC commands (/ ilda / n / play, / ilda / repeat 1). The controller does not respond to OSC commands from the console. Running the show also does not happen.

    Help please understand this problem, the authorities swear, the deadlines are tightening. I need to make it so that I can run the show automatically, via the autoplay.txt file

    Thank you in advance for your cooperation.

  5. #35
    Join Date
    Aug 2008


    Try removing the spaces in the osc addresses like this:

    /ilda/pps 30000
    /ilda/fps 30
    /geom/size 0.3
    /geom/offset 0.4 -0.2
    /ilda/play file.ild

    The Ether Dream listens for OSC messages on UDP port 60000. When it sends a response to a message, it will send that response to port 60001 on the originating host.

  6. #36
    Join Date
    Dec 2017


    Hello, Robin. Naturally, there are no spaces in the teams. I copied this incorrectly.

    I'm launched wireshark and saw that there is no activity on port 60000 and 60001. ED2 sends only broadcast messages to the udp port ( If I send the command /ilda/ or /fps/ or /pps/ from the host, wireshark shows that the packets left my host (port 40288) to ED2 (port 7654), and returned from ED2: 7654 to my host: 40288 ( UDP).

    Please tell me, which side need to look for a solution. Thank you.

  7. #37
    Join Date
    Jul 2008
    My momentum is too precisely determined :S


    What program are you using to send the OSC messages? Can you convince the program to send to port 60000 instead?

  8. #38
    Join Date
    Dec 2017


    I'm using the Linux console. I send commands from the python, through the liblo library. I do, as in the ED2 manual, I send the following:
    import liblo
    dac = liblo.Address ("", 60000)
    liblo.send (dac, "/ilda/1/play")

    ED2 is connected to the router via a wire. The port 60001 from ED2 to my host was flown to the routers. On the host in iptables, the table in the default state is empty.

    Maybe I need to somehow configure iptables?

  9. #39
    Join Date
    Dec 2017


    Sorry for the long answers. We have a time zone difference of 10 hours.

  10. #40
    Join Date
    Dec 2017


    1. Information when i turn on the utility and send request /ilda/1/play:

    IP Address:
    Version: hardware 10, software 2
    Status: online, prepared
    Source: file playback: no playing, repeat off
    Network: ok (2ms)
    Firmware: r310-4288429

    2. Output from the console when i start the

    - Buffer: 0 points
    - Playback: 0 kpps, 0 points played
    - Source: 1, flags 0x0

    3. Output from the Wireshark when i send request /ilda/1/play:

    108 56.055326903 OSC 64

    Frame 111: 64 bytes on wire (512 bits), 64 bytes captured (512 bits) on interface 0
    Linux cooked capture
    Packet type: Sent by us (4)
    Link-layer address type: 1
    Link-layer address length: 6
    Source: HonHaiPr_76:e0:7c (0c:60:76:76:e0:7c)
    Unused: 0002
    Protocol: IPv4 (0x0800)
    Internet Protocol Version 4, Src:, Dst:
    0100 .... = Version: 4
    .... 0101 = Header Length: 20 bytes (5)
    Differentiated Services Field: 0x00 (DSCP: CS0, ECN: Not-ECT)
    Total Length: 48
    Identification: 0x3fd0 (16336)
    Flags: 0x02 (Don't Fragment)
    Fragment offset: 0
    Time to live: 64
    Protocol: UDP (17)
    Header checksum: 0x78d2 [validation disabled]
    [Header checksum status: Unverified]
    [Source GeoIP: Unknown]
    [Destination GeoIP: Unknown]
    User Datagram Protocol, Src Port: 35651, Dst Port: 60000
    Source Port: 35651
    Destination Port: 60000
    Length: 28
    Checksum: 0xdbe4 [unverified]
    [Checksum Status: Unverified]
    [Stream index: 2]
    Open Sound Control Encoding
    Message: /ilda/1/play ,
    Path: /ilda/1/play
    Format: ,

    The problem is not solved. Is there any solution?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts