Results 1 to 4 of 4

Thread: LSX master beam issues with midi

  1. #1
    Join Date
    May 2018
    Posts
    2

    Default LSX master beam issues with midi

    hi,

    Im having issues with LSX and running a live show(live variable speed) with midi configured through an Akai APC40.
    the issue is when Im jumping to a time using the on screen keyboard it disabled the midi inputs I've sent through the APC40.

    it also blocks me from using midi inputs until I open up the master beam on screen and reset all sliders.
    I can then use the midi controller to set faders in master beam.

    I have been able to get it continue master beam effects twice but only on specific keys. I've saved the show and exited LSX and those keys went back to responding the same as all the other keys.


    I've attached how I currently have the keys edited, One pic shows how it was set up when it was working and the other shows how the other keys were set. which is exactly the same.



    Troubleshooting I've tried is
    restarting LSX (which stopped the keys that were behaving normally from working)
    checking and unchecking enable live sliders
    clicking on the buttons on the right to enable and disabled live sliders.


    I haven't set up the keys from the onscreen keyboard on the APC40 mostly cause I haven't looked to deep into remapping tool. I don't know if that is related though.


    any assistance would be amazing, the alternative I've figured out to this is putting events in the shows time line with the same effects as master beam which, is a bit of a job when compared to just being able to load the assignment settings.
    Attached Thumbnails Attached Thumbnails not working.PNG  

    working.PNG  


  2. #2
    Join Date
    Jul 2008
    Location
    My momentum is too precisely determined :S
    Posts
    1,764

    Default

    Please confirm that this is what happens:

    - Hitting keys on the APC while show is playing jumps to specific region on timeline
    - Moving faders on the APC moves the corresponding Masterbeam fader
    - Hitting a key on the on-screen keyboard jumps to specific region on timeline
    - Keys and faders no longer work on the APC



    LSX will remember the masterbeam fader settings per key (jumping to another key will change the faders). However it shouldn't disable them.

    I have tried to reproduce your issue but failed. Can you give a step-by-step instruction on how to trigger the bug?

    What LSX version are you using?

  3. #3
    Join Date
    May 2018
    Posts
    2

    Default

    Thank you for, helping

    Version is 20180422,

    Im not using the APC to jump to a timeline, Im using the on screen keyboard in LSX.

    - Hitting keys on the APC while show is playing jumps to specific region on timeline | Im not using it but some of the buttons that match up by coincidence do this
    - Moving faders on the APC moves the corresponding Masterbeam fader | No this stops the fades working too
    - Hitting a key on the on-screen keyboard jumps to specific region on timeline | Yes
    - Keys and faders no longer work on the APC | Only the master beam faders. events set in the timeline with faders set aren't affected


    Create new show
    add frames into timeline from frame picker
    set to live variable speed. (does the same thing on Time Internal clock)
    click on a random key
    click set all keys automatically then clicked cancel

    Then I put it in play with edit
    set faders to something ie scale or rotate
    click onscreen keyboard jumps to a time
    beams go static frame, or only are taking input from timeline events (from what you said, this is normal behaviour?)

    I then go to adjust a masterbeam fader on apc or on screen, and it won't do anything
    I then click reset sliders of all keys
    I am then able to adjust faders on apc and on screen.

    if jump to another time it will disable the faders again and I have repeast the last two steps.

  4. #4
    Join Date
    Jul 2008
    Location
    My momentum is too precisely determined :S
    Posts
    1,764

    Default

    I did exactly those steps and encountered no issues. It's best to contact drlava about this since it must be something unique to your system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •